PS3 internet connection error
  • hi

    My PS3 obtains my ip but when it comes to internet connection it fails, and says something about a DNS error.

    Could u tell me how i can fix this probem please?

    And also, could u tell me if i need to open any ports, which ports they are, and how i open the ports please?

    Oh and i have a Belkin wireless router if that helps.

    Please help im desperate ive been trying for days! and its so frustrating that i cant figure it out
  • A DNS error usualy means it either cannot get the correct DNS server numbers or the ones you have in (if entered manually) are incorrect. These numbers should match what was set for you by your internet provider- contact their tech support to get the correct numbers.. Once you have those enter them into your connection settings on the PS3 and give the test another try.

    If things still don't work you will have to try the port forwarding. This is in the Firewall section of the router under "Virtual Servers". The ports you want to open can be found here in the second post. In the first blank put the IP address of the PS3 itself. In the menu next to that select the type (TCP or UDP). In the next two blanks put the port numbers as listed in the link i gave above. Single port numbers get put in each blank (for example, port 80- just put the number 80 in both blanks). Then check the enable box to the right. Once all of the ports are listed and checked hit the Apply Changes button at the bottom.
  • thnx, one more thing... do i need the proxy address aswell?
  • No, you shouldn't need the proxy address.
  • ok thnx...i got the DNS im going to try now
  • I've done it all... rang my ISP got the DNS and it still says DNS error!

    have you got any more tips for what to do?
  • One othe thing to try is to place your PS3 into the router's DMZ or unprotected area. This puts it outside of any protection the router's firewall may give and should let any/ all traffic through to it. Did you try the port forwarding as well?
  • yeah i thougth i did the port forwarding but it seems i may have done it wrong, im going to try and find the ports i need to open
  • Well...i tried the port forwarding, and still DNS error.

    what can i do now?

    I also get the error code: 80710102
  • As i suggested above, you could try putting the PS3 into the router's DMZ, which would put it outside of whatever protection may be blocking the traffic. You will have needed to set up a custom IP address for the PS3 for this, which can be done in the DHCP section.
  • I'm sorry, but i do not have a clue how to set up an ip address for the PS3, im in the Dhcp settings bit...but i dont get it.

    And does the 40gb model support wireless?
  • Yes, the 40 GB fully supports wi fi. The only model that didn't is the now-discontinued 20 GB.

    Let's forget the custom IP address for a moment- maybe you should look at the MAC Address filtering located in the Firewall section. Go to the PS3's Settings menu and down to System Settings. In here look up System Information to find the PS3's MAC Address. Enter this into the MAC Address Filtering on the router exactly as shown and click the Add button. Whn done hit the Apply Changes button.

    It's possible after doing these changes powering down the router for a moment and then plugging it in again may help clear the figurative cobwebs inside.
  • Right ive done this, what now?
  • After doing that give the PS3 another test run on connecting online. If you are still having problems after that you may want to ask belkin or Sony about it- there seems to be quite a bit of trouble getting these belkin routers to work properly with the PS3 online.
  • Yeah i tried it again...and doesnt work...i went onto the Belkin website and theyve pre-released a new firmware, this firmware was made because there was problems with Belkin routers not working properly with Virginmedia. So i downloaded this firmware and still nothing.

    So do you think my best bet is to contact Belkin or sony still?
  • I think so, yes- they are no doubt more familiar with the way the Belkin router handles things than I am. There must be some small thing we are missing here but I just can't put my finger on it at the moment.
  • ok then, thnx for the help