Monster Hunter Freedom GS ruststone problem :(
  • Ok in MHF i have these ruststones and i used to offline method of changing them from odd weapons such as iron lance to +knight lance to rusted lance
    but whenever i get a great sword rust stone which is what ive been trying to get out of all the rusted weapons it will never turn into a rusted great sword, it just stays at iron sword and never changes no matter how many times i do missions to reset the weapon.

    Can anyone help explain why this is happening to just the great sword and not to any of the other weapons i already have a rusted version of all the other class weapons, gun, sns, lance , hammer.

    I just keep doing quests and more quests to see if the items sets will change, some of them do such as the hammers they got to +war hammers but the lance and gun and the great sword wont change and i haven't seen any of them turn into a rusted version yet, is there like a bug if i have so many ruststones that it wont give you a rusted weapon or something?

    Ill just keep at the quests maybe it just takes along time if i have alot of stones or something, kthxbye
  • There's no bug like the one you are thinking of. Take the Flat Ruststone to the Equipment and Crafting Shop (located in Pokke Village), talk to the weaponsmith, select "weaponcraft" then select 'create weapon". Look for the "??????" signifying the ruststone (you may see this twice if you also have an ancient stone of the same type). Select that and you should get your great Sword.
  • This is monter hunter freedom 1 there are no flat stone or nothing they just all say ???? and stuff.
    From what the gamefaq ancient stone guide said was after you get a ruststone you save when you finish that mission then you go and polish the stone and see what it is and if its not a rusted weapon exit game without saving reload game but instead of polishing the stone right away do a quest and finish it and then polish the stone and they said it usually changes, this has worked with every weapon except the great sword ruststone no matter how many times i do missions.

    Also thx for replying.
  • I sold off all the ruststones except the Great sword one and kept it in my bankbox thing, and im still continuing to do quests to try to reset it from a stupid iron sword to a rusted sword but still not luck i don't know why it wont work for this sword and it worked for all the others i have all the other rusted weapons and i got them after like 1-3 resets of the weapons.

    Is the great sword different or something, btw this is MHF1.
    Can anyone help?

    Also ive been reseting the weapons using both G quests and the elder combine item potion quest does it not reset the item if i do G quests?
  • For the love of me i just can not get the Great Sword Ruststone to reset from iron sword to anything eles but a iron sword. It worked perfectly fine with all the other weapons i just don't get it :(