Unable to switch from NAT 3 to NAT 2
  • Problem description: This is kind of a quirky problem. I have 2 computers and my PS3 hooked up to my Linksys BEFSR41 router. All of them can get online and browse just fine. However, my PS3 is having problems staying connected to multiplayer games in GTA IV. I am constantly getting a "Connection to one or more players has been lost, returning to single player..." error. Asking in games hasn't helped really. I've also learned that I need to set a static IP address, and I can't seem to figure out how to do that (I'm on Qwest Hi-Speed DSL with a 2Wire modem. If necessary, I can provide the modem number).

    Attempted fixes: I've done some research into changing NAT types and setting a static IP. According to advice I have seen, I have the following ports forwarded and enabled for the PS3's IP address:

    TCP: 80, 443, 5223, 10070-10080
    UDP: 3478, 3479, 3658, 10070

    Additionally, I have disabled DHCP. Another thing I have tried and reverted is setting the PS3's IP in the DMZ for my router. It didn't fix the problem, but it disabled internet usage for the rest of the computers on my network, so I turned it off again. Not sure if I adjusted it right.

    Recent changes: None. Just the router adjustments previously described in the above.

    Operating system:Windows XP Home

    System specs: AMD Athlon 2500+, 1.84 GHZ, 1 GB RAM. Linksys Router BEFSR41.
    Qwest 2WIRE modem.

    I have Googled and read the FAQ: Yes.

    Thanks in advance for any help you all might be able to provide
  • Do you play any other game on multiplayer? Do you keep disconnecting from these games...? It may just be a problem with GTA , not your system. The online on GTA can be a little unstable at times, i myself have been disconnected several times before, with the same message. Usually this has been because the Host has a dodgy connection, or there has been a small drop in my connection and i've been signed out.
  • Actually, Beefy, i would suggest turning the DHCP back on- you'll just have to add the other computers into the client list as well. To add to the client list click the button that says "DHCP Client Table". You should see a button here to add to this list- click that, enter in the MAC Address of every device you want to go online (for the computers you can find this by going into the command prompt in the Start menu and type "ipconfig /all", your PS3's can be found in System Information under System Settings in the Settings menu).

    Opening the ports as you did should have brought you down to NAT 2. Sometimes, though, the router needs to be turned off and on again to get the changes to show/ kick in.