Matrix: Path of Neo doesn't go past autosave screen
  • Hopefully this is a real easy question: I'm a ps2 newbie, please be kind!;)
    I just bought a used copy of Path of Neo, and the opening segments play fine, and then it gets to the screen that explains the autosave feature, with the red pulsating capsule. At the bottom of that screen, it says the usual:
    Press X to continue....
    Pressing X does absolutely nothing. Pressing any combination of buttons does nothing. There is no getting past this screen. Checked the disk, very good shape. Tried the controller on other games, it works fine. 8Mb card in the 1st slot, lots of room on it.

    So I emailed the ebay store I bought it from and they sent me another one. Very good condition disk, does exactly the same thing!:eek:

    Please tell me what I'm doing wrong? Is this a common occurrance with this game?? Is there some secret way to get into the game? For 2 good condition disks to be doing exactly the same thing, I'm thinking it's not the disks, but something I'm not doing!
    Thanks in advance for your help, so glad you all are there!
  • No, there is no 'secret' way to get into the game- as far as i can tell pressing X should allow you to continue...?

    The game may be having trouble creating an autosave for you after you press X. Have you tried giving your memory card slot, and the memory card itself, a little blow inside to release any dust inside them...?

    Other than that all i can think of is that you may be running into a batch of defective games from the Ebay seller. Does the game in any way look like it's been copied (not a retail copy)...?
  • They look like real copies, they flash up the Playstation 2 thing at the beginning and have full color graphics on the disk itself.
    Tried fiddling with the memory card, didn't work. The card and everything works just fine on other games, but these 2 copies of Path of Neo, nada.
    Thanks for your time, thought maybe there was something simple I was missing...guess not.
  • I can't be 100% sure you're not missing something simple, i'm afraid- having not actually played the game myself.

    The only other thing i can think of is the red capsule you talk about. I originally thought this was a 'Loading' symbol (which it probably is), but i've read that somewhere in the opening segments you have to choose between a Red or a Blue pill. Are you sure you do not have to highlight anything first (like the red capsule) and then press X. It's a long shot, i know.

    If you can't seem to get it fixed, i would reccommend demanding a refund from the Ebay seller. When you get the refund either try buying another copy of the game (from somewhere else), or spend your money on another title.?
  • Yes, I have read that about the red and blue pill, too, but I'm not getting that far. It's like a loading page, or the page before loading, and it goes no further.
    The seller was more than willing to refund the item + shipping the first time, but I asked for a replacement copy, which came today. I just want to make sure it's the game and not ME; I'm sure there will be no problem getting a refund. I got LOTR Two towers at the same time, it's perfect.

    Thank you for your time and attention.:)
  • Well it definitely sounds like the game to me. If it says Press X to continue, then pressing X should allow you to continue, it's impossible to miss anything. It sounds like there's some loading/ saving issues with the disk and your PS2.

    I think you should go with a full refund with this one, amysmom.;)