guitar hero world tour
  • our ps3 is not recognize the world tour microphone. it tellls me to go to audio device settings and select the logic tech setting. this does not show, anyone wanna help the cluless one
  • This is taken directly from the support page at Activision for the game:

    Do the following to setup your microphone:

    1. Insert USB connector into an available USB port.

    2. Go into Settings>Accessory Settings>Audio Device Settings and make sure the Input Device is set to Logitech
    USB Microphone.

    3. While speaking into the microphone, the graphical bar at the top of the screen
    should be blinking in the green range. If this is not the case, use the Microphone Level option to
    adjust volume levels and/or adjust the microphone distance from your mouth until a satisfactory
    volume level is achieved.

    4. The device is now ready to use in-game.

    When in the audio device settings highlight the device area and hit X- you should be able to switch this from "system default" to "Logitech USB Microphone" then hit X again to set it.