selected wrong language
  • how can i go back and select english on my psp
  • Go to the Settings menu and go into System Settings (just below the photo settings). The second option in here is Language. Highlight this and hit X, this will bring up the language selection menu. Highlight English and hit X again.