Ps2 Online Troubles
  • Hey guys, I am new here.

    I just bought a used (but very well taken care of) slim, silver Ps2. It works great except for one thing: I can't get online. Well, I can, but it won't list any games I can join. The game I am playing is Star Wars Battlefront. Usually, when you sign on, you can select which level, etc. But, it does not give me that option, and just skips to the "select a game to join" screen with a blank list.

    I think it might be something to do with the specific Ps2. I have been borrowing a friend's slim black Ps2 to play online since I do not have a network adapter for my big Ps2. Anyway, I ran through the set up exactly the same for both systems, but my silver system is giving me problems. I have been playing the slim black one for weeks now without any problems.

    I have no idea where to start, although I can say that the silver Ps2 DOES still have the warranty sticker on it, so I don't think it has been taken apart. Any suggestions?
  • Best solution I can see would be to go into your router's settings and set up the silver PS2's MAC Address into the router's DHCP Client List. With this done you should be able to tweak other settings such as set up a custom IP address for the silver PS2 and edit this into the settings of it.
  • about I complicate things! I just tried a different game, this time Battlefront II and I can play online with that game. The problem seems to be just the first Battlefront, which makes no sense to me because it seems like if one works, both should, right?

    Would you have any possible solution for the "new" problem? I don't have any other online games, just the two Battlefronts.
  • Actually, that maybe simplifies things. Odds are good the servers for the online portion of the original Battlefront have, in all likelihood, been shut down by now as most would have moved on to other games.
  • I thank you for your continued help, but the servers are not shut down because I can still play using the borrowed slim ps2, just not the one I have purchased. The thing that really frustrates me is that it works for one, but not the other! Grrr