• About several months ago I bought Crisis Core for my PSP. However before I could play the game I needed to update the offical Firmware directly off of the UMD disc. This is where the problems started.

    The download seemed to work fine and I plaed all the way through Crisiscore fine-however I started noticing that if I tried exiting out of the game b pressing the home key, the gre screen would come up but i would be unable to selected YEs or No instead I would hear the game continue to to play as if the game wasn't there to start with

    I didnt play on my PSP for several month, I then decided last week to start playing on FFT however I was unable to slect wmy game save- the game save screen came up but I was unable to select. This was the same for every other game I had except Crisis core. I tried to reset the psp to factory settings, this didnt work- I tried accessing the internet from my psp and the screen appears for a millisecond before going back to the menu the same can be said for the screen in which you change your devices name. Please HELP!

    I have tried downloading the newest Offical Firmware-again this hasnt solved the problem.

    It is a slim and lite psp and I have never put any custom firmware on my PSP- it has only ever been offical.:mad:
  • Lilly, have you tried grabbing the very latest firmware from Sony's site and transferring that to your PSP via USB? I have a feeling that firmware you used from the disc would still be a couple of updates behind.
  • I have heard that you can use the pandora method to unbrick any psp.I know people use this to put unofficial firmware on,but you can use it to put the proper sony firmware on and set it back to standard.Might be worth googling
  • hello my psp is dead..you know my psp has got foldrs right i accidentally deleted all those folders and now my psp wont even turn on..:( pelase help
  • Alvon, as i said in your other threads you will need to contact Sony for help here. They will likely need to have you send it in for repairs/ replacement.