Net play trouble connecting to other player
  • Hi!

    It's me again. My brother and I have successfully connected our PS2s to the internet, and we have three games with net play (Rainbow Six: Lockdown, Brothers in Arms: Road to Hill 30 and Brothers in Arms: Earned in Blood).

    Both of us can log on using all three games and enter the 'lobby area'. Both of us can see one another and in Road to Hill 30 the 'ping' square is green. We can both create games, and we can both see each other's created games.

    But we cannot join these games. In all three games it persistently tries to connect and then fails. It doesn't matter which of us creates the game and which of us tries to join. We have tried both in all three games without any success whatsoever.

    What are we doing wrong?
  • Dear moderator,

    I most humbly apologise. I realise this post should have been placed in the games section rather than the hardware section. Please accept my apologies.
  • Actually, for something like this the hardware section is the right place. :cool:

    I would suggest that you (or your brother, seeing as he has just hooked up) check your port forwarding if going through a router to get the PS3 online. Not being able to hook up suggests one or both may have a key port shut down to let the other through. You'll find the ports needed to be open in the PS3 Console section (they use the same as the PS3).
  • Thanks very much. However, it is a PS2. Will that work along the same principles?
  • We have now assigned his PS2 a static IP address as well.

    Then we tried forwarding to the ports. This works fine on my DLink router but seems problematic for his Belkin router.

    In order to circumvent this we both used the DMZ function on our routers and entered the respective static IP addresses from our PS2s. Still it will not connect.

    In the Brothers in Arms games we can still see each other, and in the 'lobby' we can send each other written messages, but we cannot connect to a game created by the other.
  • We have now turned off the firewall on the Belkin router as well, and yet find the same problem. This is really frustrating, as we only bought the PS2s to play each other online and we can see each other, send each other messages and yet cannot play each other.

    Please is someone able to offer any advice on how to resolve this?