Save Data not loading
  • I've got a question that's been driving me a little nuts and I haven't yet found a solution.

    I bought dot.hack//G.U. vol. 2 several months ago (just to see what it was like) and loved the game. I beat it and saved my clear data like I was supposed to. I then bought a copy of vol. 3, but my clear data won't load. It's saved as "clear data" or "save data" (can't remember which) but it's still giving me the blues.

    The guy at the local shop said my data was probably corrupted, so I'd have to start over. I figured if I'm starting over, I'll start with vol. 1. So, about two months ago, I finished vol. 1 - clear data saved. When I tried to load it for vol. 2, it said that no clear data was found.

    The memory card I have is an authentic Sony PS2 8 MB memory card. A friend said I should get a new MC and format it then save my data. I did, a 128 MB authentic Sony card, but with the same result.

    I'm trying to sort out what the problem is - corrupted data (I can load it for that volume and play 'til my heart's content), something with the versions of the games, or the PS2 itself, in which case I might just cry. Any suggestions?