PS3 all of a sudden stopped connecting to net (wired)
  • Hi all,
    im having a problem with my PS3 and the internet. For 3 months now my internet set up has been this:
    wall socket > modem > switch > ethernet to computer & PS3
    This has worked flawlessly until now. I was playing PS3 the other night online and then the next afternoon i went to go online again and my PS3 just wouldnt connect to the internet, when i go to test internet connection it doesnt even get past IP address, it just says "request for IP address timed out" Ive read that when connecting new devices you must reset your modem for it to allocate another IP address, but the thing is the PS3 has been in there for ages :S . I have tried resetting my modem settings, PS3 settings (except i havent manually put in all the details like DNS, etc. -- im hoping to avoid that!) and to no avail. If i connect the modem directly to the PS3 it works fine too, its jsut when I port it through the switch. i thought my net was down due to a storm we had between the night i played and the next day, but that isnt so and the switch is functioning fine as i can receive internet on my PC. Any ideas of what i can do??
  • Honestly, i would replace the switch with an actual router for sharing the internet. Something about switches some people don't realize is they split the speed between devices being connected- if your internet speed is 10 MB, a switch will give 5 MB sped to each your PS3 and the computer. A router, meanwhile, can let everything connecting have full speed.

    A router will also let you tweak settings more to get the most from your connection.
  • Hey, thanks for the fast reply. Yeah, i would get a router but im just aggravated that it worked flawlessly up until now. I could play games online & go on youtube, etc on my comp and there was no drastic slow down. Even when my net was capped black ops ran lagglessly (word?). Do you have any other suggestions other than buying a router?
    I resetted the PS3 to factory default, now in the system settings > system info page it says ip address (didnt before) but in brackets it says private network only...?
  • ok i finally got it working! i dont know how this worked, but it did. In case there are others out there with a similar problem heres what i did;
    Since i have three ethernet cables plugged into my switch (one going to PC, one to PS3, one to modem) i thought id play around with the arrangement of those. Originally it went from 1-4; cable to modem, cable to PC, cable to PS3, empty. I swapped the PC and PS3 one, which made only the PS3 connect to the net and not my PC. From the network and sharing center it said my PC was 'identifying' the lan connection and i could not log in to my modem. Then i disabled the actual LAN adaptor in manage network connections and after re enabling it i unplugged both my modem and switch for 15 seconds. My pS3 again connected to the net and my PC did not, then i simply swapped the two ethernet cables back to the original state and they both worked. Now in my modem settings there are two DHCP clients, which is what i was trying to add this whole time!!!