My PS3 wont allow any connection to the internet
  • I have a PS3 that I bought the day the system released. When I attempt to set up a connection through the connection settings it asks to select the setting method, I choose Easy -> it prompts me to connect an Ethernet cable. The ethernet cable is connected.
    I asked a friend about the wireless connection and he showed me on his console how it asks whether you want to do wireless or wired going through this process. My PS3 skiped this prompt and went straight to wired.
    What can I do, its driving me insane
  • I would suggest clearing out any settings (if any) already set up on the PS3's network section then disconnect the ethernet and shut down the PS3. Re-connect the ethernet cable while it's turned off and power cycle both the modem and the router. Start up the modem first and then the router (wouldn't hurt to double check the ethernet cable's connection into the router, maybe switch up the slot it is in).

    Once this is done start up the PS3 again and give it another go with connecting the PS3 online. You should get the choice of setting an internet connection wired or wireless after this.
  • how do i go about clearing the network settings because it doesnt give me that option either. the only way i can see to do that would be to restore the system to default settings, but that may not work either and i'm hesitant to try that.
    would the sytem restore work or any other suggestions?
  • Ignore the bit about the settings reset. Go with the rest of what i said above though.
  • ya ive gone through all the router resets and what not, ive tried to get it to work at a friends place too and the same problem happened. plus we have a 360 on the same router and no problems.
    my brother had the console for a year and said he had the same problem, so its something in the console thats messin up.
    but like i said it wont allow me the choice to go wireless anyway
    another bit of info, when i tried to connect via av it wouldnt recognize the cables and i went through a whole mess to change the settings, on a newer tv than i have, while connected to hdmi so it would work on av, so i'm imagining there is some similar issue in the system that isnt allowing itself to automatically recognize new settings but is stuck on the current ones.
  • The easy way to get it to find the output settings is, when turning the PS3 on, keep holding down the power button until you hear a second beep. This has the PS3 find the correct output and adjust accordingly.

    Just a guess at this point but maybe that same trick will help it find the ethernet cable too.
  • I tried that holding in the button manuver while having the ethernet cord connected and with it disconnected and the problem is still there.
    any suggestions or thoughts on why the ps3 is bypassing giving me the option to connect wirelessly or wired. as far as i can gather there may be something wrong with the ethernet input because it doesnt even recognize the cord being connected.
  • I had this happen before to me and the quick fix was to swap cables around on the back of the router, plugging the PS3 ethernet cable into one of the other output jacks. Have you tried this?
  • ya Ive tried that, and on different routers at differnt houses not just on the one at my house. also i connected it to the same cable that works for our 360 and still nothing. im more concerned that it wont even give me the option to connect wirelessly but goes straight to prompting me to connect an ethernet cable when attempting to setup the connection.
  • I can see it not giving a prompt if this is a 20 GB system as it wouldn't even have wi-fi available.

    Sounds like you will want to get the system checked out as it does sound like the issue is with the ethernet port.