brand new slim ps2 isn't working
  • i got the slim silver model yesterday and i'm having problems already. i'm thinking i'll just have to exchange it, but i wanted to make sure i wasn't doing something wrong first (this is my first game console ever).

    everything is hooked up, power comes on, controller works. but it doesn't seem to recognize that there's a disc inserted (the disc does spin). the manual said that the first time the console is turned on, you get a set up menu to select the language and everything.

    i can select a language, but the next screen is to set the time zone. this is where i get stuck. the time zones just keep scrolling by and i can't get out of the screen at all. none of the controller buttons do anything. i've tried resetting, unplugging, moving the console to make sure there was plenty of air circulation. i unplugged it overnight and tried it again this morning and had the same problem. is it just a dud?

    thanks for any help.
  • Hmm- odd. Sounds like the d-pad or stick might be sticking on the controller, not a fault of the system itself. Try borrowing another controller from a friend and see if it works correctly. If it does then see about getting the controller exchanged.
  • it works fine on the language selection screen though. it only gets stuck at the time zone screen, every single time.
  • Doesn't hurt to check all factors before going through exchanging the entire system. Whichever way it goes you are covered under warranty and Sony will replace things free of charge considering it's a new system.
  • ok, i feel a little silly. :redface: i have guitar hero and i had the controller hooked up to the console, so that's what the problem was. apparently it messes up the initial setup process. so ultimately it was a controller issue, but not what i had in mind when you mentioned it. thanks!!
  • Happens to the best of us- glad to see things are figured out now. Have fun with Guitar Hero!:cool:
  • cwalk79 said:
    ok, i feel a little silly. :redface: i have guitar hero and i had the controller hooked up to the console, so that's what the problem was. apparently it messes up the initial setup process. so ultimately it was a controller issue, but not what i had in mind when you mentioned it. thanks!!


    No need to feel silly, I've done the same thing myself with the SG controller still plugged in. I was viewing a DVD and thought my machine was possessed by the devil (again) damn thing was skipping & fast forwarding.