• i put a cd in and press the power button, but it does not run the game, and goes to a screen which says to insert a cd, so it is not reading cds, what is the problem
  • There are several possibilities. You could try giving the lens a bit of a cleaning using a q-tip and a very small bit of isopropyl rubbing alcohol. If it isn't the lens you may want to try cleaning the disc with a soft cloth, going from the center out to the edge without following the grooves. If after both of these the system still doesn't want to work the drive itself may be done and will have to replace the system altogether..
  • Hi, I got the same problem. However my PSOne reads audio CD's so that might not be the problem. I somehow can't get out of the CardReader/Audio setup and startup in the Game mode. I also don't see the Black PS screen that normally follows after the white/yellow diamond startup screen.

    Other ideas of how to solve this?

    - Dutchin8r -
  • If it can read other discs but not the game discs you may have to check the bottom of your game discs. If they are too dirty/ scratched the laser won't be able to pick up the data.
  • Hi Lyndon M. So I reduced the fact that the laser might be not working propperly since it does play the audio CD's. Next I reduced the fact that the game disk is scratched because I tried all the disks I had from that time and also bought a complete new game (hahaha............. costs:
  • The only other option to try would be try the games in another system. Something is definitely amiss enough in your system that it will not read the games.

    Your memory must be off a bit with the key sequence- there never was one to hit to boot up into the game.