Cheats won't work
  • I'm trying to use the "Unlock Everything" cheat for Destroy All Humans! 2 and it's not working. I'm following the directions EXACTLY and the cheat is still not working! :mad: Also, there are some cheats where you have to use numbers. How do i use numbers for Destory All Humans! 2???? :confused:
  • The cheats with numbers in them require the use of a GameShark or Pro Action Replay, a cheat device which can be found in many game stores. Without it those cheats are useless. I'm thinking this is the case with the "unlock everything" cheat you are trying as well.
  • no i tried the same thing didnt work had no #s or letters
  • I don't think an unlock everything code acutally exists. I haven't ever seen one in a game before, including gameshark/codebreaker codes.

    The code we have listed is:

    Pause Game And Hold Down L1 And R1 And R2 And Press X X Circle Square X Square X Circle. And Then Everything Will Be Unlocked. You Might Have To Try It A Few Times Because You Have To Do It Super Fast Or It Does Not Work. But I Am Telling You This Cheat Works Try It Out For Yourself

    Let me know if this is the code you're talking about. If so we will see what we can do to get it off the cheats page.
  • Yeah at first I could not use the unlock all things cheat I was frustrated:mad: but when I typed it in super fast I got everything:D hope this helps.