• If you are having problems in the game Daxter feel free to post in here and we will do our best to help you out.
  • Sorry, I may of posted my question in the wrong area. Well I'm just a little confused on the daxter game. after killing the queen bee it sent me back to kridder ridder. or w/e that's called. and then daxter said something like "all this work sure does make someone sleepy" and there was a yellow light thing above his bed and I went to it and it made me play this game that was i guess his dream. and I didn't like it so I exited it and then i don't know what to do from here. it won't let me out of the kridder ridder. and i keep looking around trying to find what I'm supposed to do next but I can't.

    Please help.

  • You did hit the right place with Customer Service, Ashley- we just move the threads to the right spot after answering there. Either one works. B)

    You do have to play those dream sequence minigames in order to continue. Thankfully it doesn't last too long.
  • oh. hmm. that helps tones. thanks.
  • sorry to bother you again but, I have another question.
    after completing the dream mission thing, I was told to go to the bar. at the bar,the bar tender told me to fix the taps, or something like that. and I'm down at the bottom after killing all the bugs and gathering the green orb things what am I supposed to do now? I can't go any where but back to the top where the bar is. and there are eggs on a 2nd lvl that I can't reach.
    please help.

  • Near the end of this level is a minigame of sorts, which is how you actually fix the taps. You push the d-pad buttons and other buttons to time with as they appear in the circle on screen (kind of a DDR- type thing). Once you beat this head to the bottom level of the room and through the door. At the end of the passage here you find yourself back in the bar. talk to the barkeep again to finish things off.
  • okay. I see. that wasn't too hard... now I'm in the train station. and I'm at some place where there is this big red thing and I have to jump to it and get the eggs but I can't stay in the red area too long b/c these red flames will kill me. and like there are these blue areas where I can stand but I've gotten all the eggs and I am at the last blue area and I can't figure out where to go....

    please helpp.

  • This is just after climbing up the wall, avoiding the red laser along the way?

    Once you get to the top look around for a vent large enough to walk into- this is where to go. There is a smaller vent to crawl through after reaching the end of the first. Ride the elevator down from here to get to the lower portion of the room.
  • aha, i see now.

  • uhm, hi again. lol.. okay.. now I'm at the place where the hive queen is, and I've killed all the bugs that come out and she became a lkie giant and I keep trying to hitt her, you know by pressing the square button, but it like doesn't do any damage. am i supposed to even kill her?
  • The battle with the Hive Queen goes in about three different stages. When you first see her she's in an egg-like shape. Hit her once and then step back and destroy the bugs she puts out. After a few hits she will come out and shoot several beams. When this is happening hop over the beams and get her with the bug spray. You can then dash behind her and swat her with the bug zapper. After a few of these she gets mad and on to phase two.

    In this phase she slams the ground creating shockwaves that can easily hit you. Hover using your sprayer to avoid this and get behind her to lay i some more shots with the swatter. It won't be long before you get to the final phase. The same strategy outlined above for phase one will beat her for good here. Good luck!
  • now i'm at the fish cannery. and i've completed like everything in there. i killed all the bugs and it took me outside to like this water and stuff. and i made it across the water and up the elevator and then i've gotten all the way to this area where there are 2 areas where iceblocks can come up.
    and across the room is a second lvl that you have to like hover over to get to it. but its so high your suppsoed to use the ice blocks to get to it. i've been stuck in this area for the past few days. how do i use the ice blocks to get over?
  • If it is the spot I think you are at one of the blocks has to be slightly melted to let you get up on top.

    After melting the cube jump onto the platform to the left after you jump onto the crates that were in the cube. You should see two levers here. Keep the cube melted down to a point where you can still jump onto it. When you hit a lever another cube should come up. This one you just give two quick shots with the flamethrower. Now, jump onto the first cube then onto the one you gave the two quick shots to. Run to the edge of the cube and doublejump- this could get you enough height to hover to the cage.
  • oh thanks(:

    it helped alot.

    okay; now i've gotten to the platform and i went to the elevator and it took me up and now i'm outside.... where am i supposed to go?
  • If you are outside the next stop for you should be the Distillery (no drinking on the job now ;) ). Look for a barrel icon on your overhead map.
  • ehhh, i'm back again.(:

    i'm trying to kill the hive queen now and i was just trying to firgure out how to kill her.
    any suggestions?
  • Good to see you've been making progress on the game. B)

    Hit the hive and defeat the bugs that come out of it a couple of times and the Queen will attach it to herself. First attack she has is to fly over to a hole and slam her butt into it and then try to hit you with an energy beam out of her mouth. You can avoid the beam by hovering with the flamethrower. Hover to her and once the beam attack ends hit her with the flamethrower. This makes her fly up and hover for a few seconds, allowing you to get some swats in. After a few hits she lands on combs and fires some red bugs at you- the flamethrower can take them out.

    Run up to her while dodging/ killing bugs and use te sonic blast to dislodge her from the wall. She should eventually land in the center of the area which will let you get some more swats in. Once she is down to the last bit of health she will float over a hole, shoot some eggs down and slam into the hole. Use a sonic blast to get her out of the hole and get some swats in. She should keel over for good after a couple of hits.
  • hovering after i've hit her with the flamethrower, where i do i swat her at? i keep trying to hit like her hive but i do no damage?
  • Ignore the hive and go for the queen herself- that big behind of hers makes a good target. ;)
  • Ok, i'm not sure if i can post here, but it looks like you can help.
    i read a couple of posts and i noticed that ashely<3 was stuck in the brewery too, where you have to fix the taps. Well i finished that and got all the gold egg things but how do i get back to the bar part. I tried to go back the way i came but i always die on one of the open parts. Am i supposed to go that way, or is there another way i am to go?<br />can you help?!
  • Once the taps are fixed head down to the lower portion of this room, Gerica- you'll find the exit back to the bar here.
  • Hi,
    Help i'm stuck in the distillery level I have been completely through it 3 times now and when I get back out on the street the only icon my map shows is still the distillery. I do not know what else to do. It shows that for the distillery i have collected 51 of 60 of the red egg things and 62 of 62 of the yellow ones. Any ideas would be great.

  • There are a total of 40 gems to collect in this level. You likely did not get all of them yet. Take your time in going through and kill every bug you come across- by the time you finish the bugs in the room after the rising liquid you should have them all.
  • YESSS.
    after trying for weeks i finally killed the queen bee.
    i don't know why it took so long but i did it.
    thanks for the help.
  • uhmmm.
    i'm stuck again.
    i'm in the lumber mill now.
    and i've killed 5 of the 7 bugs that have to be killed.

    i'm on a little plat form connected to some land.
    and there are to ways to go.
    one way hoping from those litttle lilly pads. and then another way with lilly pads. I've been both ones. one way took me to kill and bug and then i had to go further on the water. and then i went to the other way and like it took me to another bug. and like i killed it and then i took the strip line or w/e. that flew me back to the little plat form. and i don't know where to go from here.

    have any idea where i'm at?
  • ashley<3 said:</div>
    i'm stuck again.
    i'm in the lumber mill now.
    and i've killed 5 of the 7 bugs that have to be killed.

    i'm on a little plat form connected to some land.
    and there are to ways to go.
    one way hoping from those litttle lilly pads. and then another way with lilly pads. I've been both ones. one way took me to kill and bug and then i had to go further on the water. and then i went to the other way and like it took me to another bug. and like i killed it and then i took the strip line or w/e. that flew me back to the little plat form. and i don't know where to go from here.

    have any idea where i'm at?

    Umm... completely lost? :p

    When going down the right hand side of the river you should see an entrance in a wooden floor- jump down here to continue on.

    You should be seeing a large river from here. Jump on the logs that are floating around and moving to get across, watching out for branches that can knock you off. You'll find the next switch to hit there.
  • I don;t know if you have got this one but try going this way as there is one more bug ...

    From the platform ...turn left and you will see two wooden logs on the water thats the way you have to go to get to the other bugs get past the wodden logs and keep going on the leaves till you reach a platform ... don;t go back where you already killed the bug ....there will be another two wooden logs get past and get to the plat form ..there will be a large wooden log ..open for you to walk through....... cross the cutting tool going up and down and you will reach a platform...

    Walk down and the other bugs will lead you to another one of those bugs...I have completed killing all the bugs but don't know how to get out ...let me know if you get there
  • hey umm im stuck at one part of the strip mine 2. i found a place where there were alot of the things i need to collect and i cant find out where to contine. i found this part where there was the greeen things i went and i was a dead end im at persentage 45 i'v been stuck for a while i need help thanks.
  • Time to backtrack a bit to the treadmill. Travel back down it and you should see the next hive to fry to the left- hover over to it.
  • ohhh thats y i thought i had to hover over all of the green things it led to a dead end! kk thanks. im at the lumber yark i think its the first one do u have any hints?
  • please help me!!!

    im at the part where the old fat dude told me to go to the power station, and i beat lumber mill, AND stripmine 1 and 2. i collected ALL the gld orbs in every place, but it still has the little lightning-bolt on the mini-map when i exit the power plant.

    IM STUCK PLEASE HELP!!!!!:( :( :confused: :confused:
  • Remember the bit at the end of the trip to the strip mine when the miner said "all you have to do now is bait the trap"? Well, you have a battle with another Hive Queen ahead of you. Just to the other side of that river of dark eco with bubbles coming out is a door- go there and use the sonic attachment to blast through a few walls to get to the battle.
  • tanks a bunch!

    it is mine 2 ... right?
  • Yep, that is Strip Mine 2.

    If you get stuck in the fight the strategy for beating that battle should be in the pinned Daxter help thread at the top here.
  • YES I FINIALY FINISHED THE LUMBER MILL.. when i went out of the lumber mill and to the haven city streets i said i had to go to the same place im stuck did i miss somthing that i should have done i need help thanks. p.s sorry i wasnt on latly their were problems on my computer.
  • You probably have to head back to do the second session with the Strip Mine, just like jimbob did up above.
  • ohh ok.. and the way to kill the bug is it the same way as i killed the first bee?
  • No, this battle is a bit more advanced. You'll be making use of the sonic attachment for the whole battle. This particular hive queen has some different attacks to make things a bit more difficult.

    Like I said, this battle was covered in one of the other daxter threads- check those out and you should find it.
  • oh okk.. on my way to the hive im lost do i need to go threw the hole place again of when i see that dude theres this door i think and i go in their?... i think i rote this in the rong section sorry.
  • No, you got the right section and the correct thread gamer. B)

    Yes, go back through the portal at the power plant and select "strip mine 2". You'll see the door just past the miner over the small bubbly river of dark eco. Go through there and you will need to use the sonic blast to blow through several walls to get there.
  • ohhh ok so i did that and i saw the hive. i killed those bugs that shoot out and then the queen came alive. when i got her half way dead she went to get some power and fire somthinings at me. i killed those. how is that going to kill the bee? thanks!! :)
  • In her second phase she goes upside down along the edge and fires those bees that home in on you. Get up close to her and zap her with the sonic blast to do damage and dislodge her. Follow her to the other side and do the same thing again. After about 3 or four hits she will go into her final stage of the battle.
  • Yes after a few thousand tries i killed the hive:P :)
    after i killed the bee i went to the tanker 2 and im stuck at a place were a break the alarm or somthing and i have to get out asap. From the rope part (swinging) i came across from that at came outside. when i came outside i jumped and turned the wheel and mad it a cross. this is the problem. After i jump the purple water i cant find a place to leave. i'v been stuck thier for a while. i was like 30seconds left and i could find my way out. Thanks
  • Once you make it across the dark eco pool there should be another stuck valve. Use the flamethrower on it and then behind you there should be a door that is now opened. Get to the end of the room and then through the hole to escape the tanker....
    Good luck...:)
  • Yeyy Im at the prison and i have some problems. After one of the gaurds chase me down the thing with the car. and i defeat him than theres another gaurd walking back and forth with a tunnel behind him. The problem is the after i go get some token i think i come back and go into the tunnel. I see some planes at the top. What am i supposed to do im stuck. Thers no way out after the tunnel and the planes. thanks
  • Ok so you've grabbed the token (a yellow key) right. When you've grabbed this there is no need to go back to the tunnel. All you need to do is go to the room on the left side of the room, after you've grabbed the key, and then crawl under the bed and there will be a passageway for you to crawl through.
    That will get you to the next stage...If you need any more help, you know where to come....;)
  • I am at the bar and i don't know where to go. I went downstairs and there is a cobweb blocking what i think is the entrance. can you tell me where to go.
  • The cobwebs blocking the door can be burned away- you should see a lantern nearby on the floor along the wall. Use the sprayer on it to light the spray on fire and give the web a quick shot.
  • got it thanks!!!!!
  • I am in the place with the 2 ice blocks that you move by hitting the levers. How do you get to the next level or the cages above the blocks. I've tried every thing except the right thing to get to either. I've been here for several days now! Please help!
  • Covered that particular spot further up in the thread, kwbare- check out post #13. B)
  • I'm having trouble in the Bar level. After the bartender told me to fix the taps I went down through the level but I can not reach the second level. I know Ashley was having trouble with this but I don't understand how to do it. Please help. Thank You!
  • There are no ice cubes there.
  • never mind im sorry i hovered over to it
  • When I spray the bug spray on the queen bee nothing happens and if i get too close to spray her she hits me. What am I doing wrong? Please help. Thank You.
  • In the first battle with the hive queen the idea is to use the hover to avoid her ray blast and hover toward her head. The gas will knock her out for a few seconds. When this happens run to the back and take a few swings with the swatter.
  • I take it you are at the stage where its the first time you battle the queen bee? In that case, what you need to do is, in Phase 1 hit her a couple of times until she smashes out of the egg. Now you need to battle her. To hurt her, you need to wait until she crouches over and starts shooting beams at you. While it is shooting these beams, jump over them and spray her then with the bug spray. Then quickly run behind her and swat her in the backside a few times. After a few more times a cutscene will show her getting mad, now you're in phase 2.

    In phase 2, she will jump up and down creating shockwaves. All you need to do is jump over these shockwaves as quickly as possible and hover to her backside. Swat her there yet again, and after a few repeats of this process, phase 3 will be upon you.

    In Phase 3, use the same strategy as in phase 1. Waiting for the right time to spray her and then hitting her in the backside while she's vulnerable. She'll be defeated in no time...:)

    Good Luck...;)
  • I have tried and tried to kill the Queen 1 and i double jump over her beams but she still hits me and then when i get too close to her face to spray her she hits me. what am i doing wrong? thanks!
  • oh thank you so much!!!
  • Yeah, have you got it? You have to get her in the backside i think Sable....;)
  • Hello. I was wondering, what are the webcodes for that you unlock when playing mini games? I tryed to find out, but couldn't get an answer.
  • I haven't come across these myself either- all i know is you get them with a Gold finish on the Matrix- themed minigames, the Lord of the Rings- themed game and the Braveheart- themed game, all of which can be unlocked as you collect precursor orbs.
  • They are actually used to unlock special content for your PSP and PC. Just go to Official Daxter Homepage, and click the secret vault link to the bottom right of the homepage. When loaded, you will be asked to enter the first of the four webcodes that are available by getting a 'Gold' rank in the minigames. If you have that webcode, then enter it....:D

    You will then get access to special content, such as wallpapers, forum avatars, soundtracks, videos etc. Enjoy Ninja Roo....!;)
  • Thank you vary much! That really helps. :D
  • After I defeated the queen, the second time, the miner said, "good job, you can leave now". I jumped through the portal to the control center and rode the scooter around but I have no directions on where to go. (I'm at 51%.)
  • At this point of the game jump right back into the portal- you will be able to select another destination, the Lumber Yard. More bugs to kill here! B)
  • im really confused. im in the strip mine 2 and i finished killing all the hives. so then i went back to to the miner and he told me the traps ready and for me to go there and squish the queen. thats where me problem started i have no clue where the trap is or if i should go somewhere else to get there.

  • Just to the other side of that bubbling creek of dark eco near the start of this section is a door- head through there to make your way to the second hive queen battle.
  • Hi...I am suck with this emarld isle...i dont know what to do here...please help..I am just going behind the bug...
  • As you are following it hit the R button to make Ximon lob grenades at it. The grenades will just do damage to it when it is above the water surface- when it goes underwater just keep following the ripples until it comes up again.
  • Oh i got it and completed it....Thank you so much
  • Hi..I am back again....
    I am at the lumber mill....also when I entered the lumber mill I was given an option to go to Strip mine, strip mine 2..do I have to play both wasn't the strip mine completed in the beginning stage of the game?
  • The strip mine is actually done in two segments, hence the "strip mine 2" indication. Head there after taking care of the lumber mill- you have a battle with the second hive queen awaiting you.
  • I just entered Strip mine 2, but not able to find the path to proceed further. The door across the purpule river is not opening.
  • Have you spoke to the Miner yet...? After talking to him, take a left. Make your way across the dark eco, then take a right and head up the treadmill device.

    I think your new Ultra-Sonic attatchment to your bug-spray should destroy things like Doors that may be blocking your way...;)
  • Thank you...I got it....I was following the right path but dint know how to destroy the doors...
  • Help me!!! I cannot get out of the wine cellar and I cannot figure out when the end of this level is. I don't know how to fix the taps. I'm going crazy in this level!:mad:
  • The taps, you may notice, are arranged somewhat to match the d-pad and button layout of the PSP. When a meter goes off, push the correct direction on the d-pad or button to "fix it". As an example, when the top meter on the left side goes off, push up on the d-pad. The pattern will change up so I can't tell you any sort of order they will go off in.

    Once you do finish this task you'll find a lower level- head right and you should find it. Follow this path back out to the bar.
  • Hi i need help! i'm at the final boss, i can maybe hit two bars off of him, but then i die, becuase after you hit one bar if gets way harder...please help!!:o
  • hi me again, im still at the final boss but im farther. now he only has three bars left, and the platform has broke. And now i don't know what to do!! please help!!
  • Follow this step-by-step guide to defeat him. It starts from the farthest point you have got in the Boss Battle (when the platforms begin to break). At the end of the day it will take a good deal of your gaming ability to defeat Kaedan, this guide will help make it easier but you will still have to do a lot yourself...;)

    He will shoot electric mines at you and just dodge them. When it shows him charging up a shot, get ready to start hovering over the path of green orbs to get to the platform where you can flame the coil and make the dark eco pool level decrease. Once it is decreased, jump to the next set of platforms.

    On the next set do the same thing, except dodge his charged shots and go to the left side of the room (facing the boss) and hover along the green orb path to flame the next coil. After you reach the third set of platforms, a cutscene will initiate and phase 3 of the battle will begin!

    This time, the boss will shoot one mine at you, dodge it and go hit him with an Ultra Sonic shot while he is charging his next shot at you. This will make him go loopy and crash into the barrels behind him and they will fall right on top of him, sticking him in one spot long enough for you to jump across the barrels and hit him in the face with another Ultra Sonic shot.

    Do the exact same thing two more times and you will defeat Kaedan.
  • Thank you, i know how to do it now, still didn't beat him yet, but i know how, thank you a lot!!:D
  • do i have to go on the barrels really fast, because i never seem to make it there in time, they start to fall. the first one was easy, but the rest i never seem to get there in time. is there a easier way?
  • There may be an easier way actually, has Kaedan destroyed the pillars yet...? If so, you can use the fallen pillars as bridges to get you close enough to hurt him.
  • Hi i beat everything. they even showed me the credits, but then i get back and it says i only have 79% complete...what does that mean?
  • Hello, I just got the Daxter game and now Im stuck in the Distillery Level. I've gotten past the first part where I have to try to jump onto the platforms before they fall and before the liquid hits me, but when I finally reached one of the platforms and jumped onto a circular one I have no idea where to go. HELP!! : )
  • Hi i beat everything. they even showed me the credits, but then i get back and it says i only have 79% complete...what does that mean?

    It means you haven't collected everything in the game. You may have missed a lot of Precursor Orbs and a few Combat Bugs for example. These can easily be collected now you've finished the main story- you're free to roam around and do as you please...;)

    Hello, I just got the Daxter game and now Im stuck in the Distillery Level. I've gotten past the first part where I have to try to jump onto the platforms before they fall and before the liquid hits me, but when I finally reached one of the platforms and jumped onto a circular one I have no idea where to go. HELP!! : )

    Can you see a lever on the platform...? There should be a lever there, once you've found it hit it and continue through the door on your left.
  • Hey,

    I dont see any lever but I have gotten a little past where I had the problem. Now Im on another circular pad and I can see the exit door but its really far away across the liquid and there's only one of the green gases postioned in a totally unreachable position. HELP
  • You are hovering with the flamethrower (not the normal green gas), taegirl...? Hovering with the flamethrower should allow you to get across this gap.
  • hi,
    right after i did the fish canary lvl i went to the place represented by a lightning bolt and i did the lumber mill lvl. there are no lvls in that portal that i have not done and the yellow light is still shining over it. what do i do?
  • There is a second visit to the Strip Mine to take on at the portal as well-jump in and select Strip Mine II- you'll have a battle with another Hive Queen coming your way.
  • I cannot get out of the train section part where daxter has to pass through the tunnel. no matter how carefully and fast i ride i still get crushed by the train. please tell me what i do wrong and how can i get through!!!
  • All i can suggest is adjust your timing a bit- there is nothing I can really say/ do to help otherwise.
  • Ok, so i killed that first queen thing by smaking her arse, and now i am on the next bit - a mine i think. I went through the spinning tunnel, up a wall, down a wall and now there is no where to go! It is very frustrating! I have tried going back but cant go back through the spinning tunnel thingy. Am i missing something? Thanks x
  • Here's a list of how to get each power crystal at the strip mine:

    1st Crystal:

    Walk ahead, and you will see a huge barred wall with a couple precursor
    orbs on it. Climb it and at the top, you will see the first crystal.
    Collect it and return to the miner.

    2nd Crystal:

    From the miner, walk ahead, past the barred wall and onto the next escalator
    path and the crystal will be right in front of you. Collect it and return to
    the miner.

    3rd Crystal:

    Now, from the miner, go to where you collected the 2nd crystal and climb
    up the barred wall. Run to the end of the platform, hit the switch, and that
    will activate the huge cylinder object and get it spinning around. Now,
    backtrack to where you got the 1st Crystal and look on the left for an opening
    to walk into the huge cylinder.

    In the cylinder, you will see a bunch of Dark Eco and platforms spinning
    around the cylinder. Just wait till the platform reachs you and jump on it
    then the next platform and repeat till you get across. Once you get across,
    the crystal is right there.

    4th Crystal:

    Now, from the miner, walk ahead and run to the right of the stage that you
    are in. You will see an opening and a couple metal bees. Kill them and walk
    ahead and grab the Crystal.

    5th Crystal:

    Go back to where you found the third Crystal, get on the floor escalator and
    press triangle to get safely under the rotating chunk of metal. Hurry and jump
    to the left and just start running up the path. To jump over the gap on the
    way, just hover and make sure you hit both the green eco pellet and the
    flame to get to the above platform.

    Run ahead, walk to the right, and there is a Crystal right there.

    6th Crystal:

    Go back to where you found the first crystal and turn to the left to find
    an opening to another cylinder. The setup this this cylinder is different
    but it is pretty easy to figure out how to get across. Once across, you
    will see the crystal, collect it.

    7th Crystal:

    Where you found the last crystal, jump on the zipline ahead and ride it down.
    That will return you to the miner. Now, go back to where you found the 3rd
    Crystal and run to the right where you will find a passage where there
    are flames to use to boost up to the platform. Now use the first one and turn
    to the right and hover to the green pellet and use the flames to boost up to
    the platform.

    Get to the elevator and have it bring you down and continue your path all the
    way to the crystal. Along the way, you will see a barred wall. Jump on it and
    crawl down to the below platform instead of up. Next, you will see a barred
    wall shaped like a circle and these metal things rotating around it. Climb it
    while avoiding the metal things and you will be fine.

    After all of that, another wall to climb and there is the crystal.

    8th Crystal:

    After the last Crystal, continue down the passage and ride the elevator ahead
    down to see a couple green eco pellets and a boosting flame. Use them to get
    across and run ahead up the path. You will see the crystal ahead and now
    you have collected all of the crystals! Use the elevators in the room (which
    are just above and behind you while facing the crystal) and return to the
    miner to complete the mission.
  • Ok, so i didnt do that, but now i cant go back! Is there a way to re-start the level?
  • Well, it's hard for me to tell exactly where you are but if you shut down the PSP and restart the game you should find yourself back in the power station in front of the transport ring to head back to the start of the strip mine.
  • hey there i c that ashley has been stuck in the fish cannery. its the same part im stuck on. i melt 1 ov the blocks then move the other 1 bt once im on the block i need to b on i cant seem to hover long enugh to gt to the cage an i jst fall an die. plez help i cant seem to wrk out wat im duing wrng. i jst gt close enugh then i run out ov gas

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter

In this Discussion