Issues With Xenosaga Episode I
  • I have been trying forever to get the first Xenosaga to work again on my PS2, but it refuses!
    I had a copy a year ago that I lost, and it worked just fine.
    I bought three used copies from GameStop, and none of them worked. I assumed it was because they were used and were too scratched. I bought a new one online, got it in the mail today, popped it in, and it still just comes up with the screen that gives me the choices between "Browser" and "System Configuration."

    I have an old PS2 that plays every other game perfectly fine. I own both other Xenosagas and have no issues with them. My game that I lost worked fine as well.

    I saw one solution suggesting to delete saved game data, but I checked my memory card, and there is no data for Xenosaga Episode I.

    This is extremely frustrating as this makes the fourth (and new!) copy I have bought that won't work on my PS2. Am I doing something wrong?
  • It may be a sign that your PS2 is starting to go down the road to full shutdown- you may want to try those discs in a different PS2 just to be sure, however.
  • Well crap...I don't know anyone ghetto enough to still have a PS2 that isn't shoved in some obscure corner of their basement...
    If it makes any difference at all, in the time between when I last played my lost Xenosaga and my buying the first used copy from GameStop, my PS2 wasn't even touched. I don't get how it could go unused and just magically stop working, but maybe my luck is just that horrid.