2 Sackboys for 1 controller in LBP?
  • With LBP2 coming out, I thought I'd give LBP1 a go. However, the game is proving a lot more troublesome than I'd anticipated. Whenever I start up the game, there are 2 sackboys on the screen, even though I only have 1 controller active. I'm not even connected to the internet and this still happens. I've done everything I could think of to fix this: I deleted my save and went back into the game. I deleted the game from my PS3 hard drive and re-installed it, with all of the patches and everything. The only thing that's left to do is to delete my profile and start over, which I'm obviously loathe to do. Is deleting my profile the only way to fix this problem? Is there something else I could do?

    Help please?
  • Only reason I can see there being two Sackboys in the pod is if someone else has joined your pod. If you are sure this isn't the case then deleting the save and starting over may be the only other answer, I'm afraid.
  • Now, by "deleting save and staarting over" do you mean wiping out my profile? Because, to tell the truth, I'd rather return the game than destroy all the progress I've made on my other games.
  • No, i do not mean wiping out everything on the PSN name. Just go into the Game Saves folder of the Game menu on the PS3, highlight the littlebigplanet save, hit triangle and delete just that save.
  • All right, I've tried that, and again I've tried wiping out LBP from my PS3's hard drive. I still get two sackboys on the screen, even during the tutorial level when the game first boots up.

    This is getting really frustrating.
  • Well, the only thing I can think of that would cause this is if you do have another controller turned on or something plugged into the USB thinking it is a controller (guitar hero dongle perhaps). Double check your controllers and disconnect anything in the USB ports.
  • One other quick thought- if you have a PS3 Blu-Ray/ DVD remote kicking around or a multi-function remote sometimes these will get picked up as an extra controller. Pull the batteries from these and give it one more go.
  • Lyndon M STAFF said:
    Well, the only thing I can think of that would cause this is if you do have another controller turned on or something plugged into the USB thinking it is a controller (guitar hero dongle perhaps). Double check your controllers and disconnect anything in the USB ports.


    Ah, this was the problem. Had the receiver for my Rock Band guitar plugged in.:redface: Can't believe the solution was that easy.

    Thanks!