Elder Scrolls IV: Oblivion - Game Help PS3
  • All I can suggest is delete the game data and let the disc re-install it. The PS3 version is buggier and, to be honest, may not be fixable.
  • Thanx for your answer. That may fix it indeed. I have a back up of my play data. Should I delete that too?
  • No, you can leave your game saves alone. That way you aren't starting over at the beginning.
  • So i just got oblivion GOTY and it simply just keeps freezing and lagging and loses sounds. Talking to other people in the game is almost IMPOSSIBLE everytime i try to talk to them game lags or freezes. And during the gameplay it just loses sounds i wait like 5 mins a screen with "Disc reading error" message appears.

    I have ps3 250gb slim EVERY other game works FINE no lags or anything else. just oblivion. :confused: please help me i want to play this game
  • Only thing I can suggest is delete the game's data from the PS3 Game Data folder then let the disc re-install it. I'll mention, however, this game is one of the buggier ones out there and it may well be the game itself that is the issue. That being said, if the delete/ re-install of the game data doesn't help there is not much more that can be done.
  • Trying to fin a mortar an pestal in oblivion, onyl very new to the game. any ideas cheers ?
  • You should be able to find one in the Natural Caverns sitting on a crate/ table after you stealth kill a goblin by a fire.
  • hi i am haveing real trouble with fathis aren in the elder scrolls
    i have found the secret passage in bravil castle
    and i am looking for a key to unlock the door to find the arrow or the wizard himself
    however i have searched everywhere and can not find either
    please help me:p
  • This should help you out, clanmatheson. Sorry about the delay.

    Head to Bravil and seek out a beggar. They lead you to the castle, so go. Head
    up the stairs over the throne and enter. Take a left and pick your way into
    Fathis' room. Look into both chests on the left to have the epiphany that the
    arrow isn't here. Go to the north wall and press the movable pillar
    to open the path to the grotto.

    Wait in this corridor for the Daedra to get into view and then try to snipe it,
    or kill it however. Take the door in front of you and take the path straight
    down a ramp to the water. Kill a single crab and follow the path to the east
    into a water area that has a deep floor. Kill a few fish and dive under until
    you find a path; any waterbreathing helps, and use your map. Follow the water
    tunnel to dry land and keep moving until you pass a gate. Save and try to
    sneak by to open a door and snipe kill a conjurer in a dead-end room, then
    come back and take on the Dremora. Pass through to a watery tunnel where you'll
    run into a nirnroot, a pest in the water, and then a door to the lair.

    Move beyond the closed double-door and follow the path to a gate; remember to
    stay in sneak. This room has nothing, so keep moving to another gate. This
    room has an atronach and a conjurer. The best thing to do is wait for the
    beast to turn away and then you go sneak kill the conjurer, or just sneak past
    them both, or fight. Whatever you choose, get up the stairs and out into the

    You have only two options here: fight all the beasts, or sneak all the way up.
    You have to get up two levels to get on Fathis' level. I say save and try to
    sneak your way up, jump along the left side by using a doorway, and then
    sneak into his room, because if you engage in one monster battle that will
    usually bring in everyone. When you reach Fathis' room, just go into the right
    corner so that he can't see you (it doesn't matter if he detects you, just so
    long as he doesn't see you take the arrow) and break into the chest to steal
    all the good stuff. You can steal more, but just get back to Chorrol.

    Give the Fox the arrow-key to get promoted and get your gold.
  • I cannot shut the first oblivion gate? as i keep being sent the wrong way when going through the gate:-(. I should not be able to meet Martin until i shut the outside gate but...everytime i go through the gate i end up right outide the temple:-(.
    Any help is much appreciated.
  • hello my ps3 said to me an error has ocured you have ben signed out of the playstation network. and when i go to sign it pops up same error msg and i have unpluged and waited for 30 sec and tried again and the same msg what would u sugest for me to try next THANKS!!
  • ok so i have the game of the year edition, but the shivering isles will not come up, ive tried about everything, ive traveled to the spot where it is supposed to be, deleted and re-installed the game data. any othe suggestions?
  • ok so i have the game of the year edition, but the shivering isles will not come up, ive tried about everything, ive traveled to the spot where it is supposed to be, deleted and re-installed the game data. any othe suggestions?
  • When you start a new game, did you get the msg asking you to check out some door (which is about the Shivering Isles)? Or the quest log. Ugh, it'd been so long since I last played... :eek: I believe the msg or quest appears some time after you got out of the prison, most probably when you sorta outside of imperial City.
  • Lyndon M STAFF said:
    There is a priest you can talk to to start the quest for the cure. After talking to him you will be directed to talk to several other people in succession before actually starting to look for the ingredients.

    Seeing as you have been told about the gems you have already made it through the bit above, however. You can get them either by stealing them from the Mage's Guild or buy from them. Once you do have them go back to the witch and she will give you a grocery list of ingredients.

    - 6 Garlic Cloves
    - 2 Bloodgrass shoots
    - 5 nightshade leaves
    - Argonian Blood
    - Ashes of a vampire

    Garlic and bloodgrass are found easily. Nightshade can be found between Bravil and Skingrad as well as at the Arcane University. Argonian blood can be had easy as well, just do not get caught trying for it. Any Argorian stupid enough to be in the right place at the wrong time will do.

    For the Vampire Dust, however, you must go to Red Water slough and find the vampire Hindaril. make your way through the dungeon here and kill him to get the dust.

    I have collected all the required items and taken them to the old lady but she will not accept the bloodgrass. keeps telling me to find some and bring it to her. i've gotten all the recommendations from the mages if that matters. i'm tired of the limitations of being a vampire. i was bitten 5 game hours into it and am now over 300. some help here please. i read the earlier posts on how to reload an earlier save but i don't have one and am really too far into the game to start over.
  • is there any way to get cured of the vampirism other than the old lady?
  • No, she is the only way to do it.
  • that sucks.. she won't acknowledge that i have any of those dang weeds at all.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook Sign In with Google Sign In with OpenID Sign In with Twitter

In this Discussion